PER EDITARE UN FILE DI TESTO: EMACS

Commenti

Transcript

PER EDITARE UN FILE DI TESTO: EMACS
PER EDITARE UN FILE DI TESTO: EMACS
1. lanciare il programma di editor:
> emacs nomefile
2. modificare il testo del file
3. salvare il file: dal menu orizzontale in alto:
file --> save
oppure
file --> save buffer as
(per cambiare nome al file)
________________________________________________________________________________
PER GRAFICARE LE CARATTERISTICHE I-V: INSPECT
Lanciare il programma di grafica XY con i file di interesse (_des.plt):
> inspect simulazione_des.plt
Per graficare una caratteristica I-V:
1. Selezionare il dataset desiderato dall'elenco in alto a sinistra.
2. Selezionare l'elettrodo a cui abbiamo applicato al variazione di tensione
durante la simulazione (anodo).
3. Selezionare dalla lista in basso a sinistra la grandezza di interesse
(OuterVoltage).
4. Infine, indicare l'asse su cui si vuole graficare la grandezza (tasto in basso
a sinistra: To X Axis).
5. Ripetere per la grandezza da graficare sulle ordinate (anodo, TotalCurrent,
To Left Y Axis).
Per graficare la caduta di tensione sulla resistenza di contatto:
1. Selezionare il dataset desiderato dall'elenco in alto a sinistra.
2. Selezionare l'elettrodo a cui abbiamo applicato al variazione di tensione
durante la simulazione (anodo).
3. Selezionare dalla lista in basso a sinistra la grandezza di interesse
(OuterVoltage).
4. Infine, indicare l'asse su cui si vuole graficare la grandezza (tasto in basso
a sinistra: To X Axis).
5. Ripetere per la grandezza da graficare sulle ordinate (catodo,
InnerVoltage, To Right Y Axis). I valori di tensione sono riportati nella
scala di destra del grafico).
Per graficare la linea con simboli
Selezionare la curva, quindi edit --> marker -->shape --> square -->ok.
Per cambiare i valori min e max degli assi:
Menu principale: Edit -->Axes...--> X Axis -->Scale
Per leggere la tabella dei dati del grafico:
Selezionare la curva, quindi Curve -->Curve Data dal menu principale in alto.
_____________________________________________________________
PER GRAFICARE I DATI 2D DEL DISPOSITIVO: TECPLOT
Lanciare il programma di grafica con i file di interesse (_mdr.grd, _mdr.dat
per il dispositivo,_mdr.grd, _des.dat per i dati di simulazione):
> tecplot_ise8 dispositivo_mdr.grd dispositivo_mdr.dat
Per visualizzare la griglia:
dal menu orizzontale in alto: tools --> ISE TCAD Tools
dalla finestra di ISE TCAD Tools: selezionare tutte le regioni (elenco in baso
a sinistra) e cliccare sul tasto 1 di M (in basso a destra).
Per fare una cutline:
dalla finestra di ISE TCAD Tools: nel menu orizzontale in alto selezionare
Tools--> X-Normal Cut ed introdurre la coordinata desiderata.
Per visualizzare correttamente la cutline occorre selezionare dal menu
principare del programma View-->Fit to Full Size, per fare uno zoom
selezionare il tasto di zoom nel menu di sinistra del programma principale.
Per graficare la cutline con linea e simboli (per evidenziare i nodi):
selezionare la freccia nel menu di sinistra del programma principale, qundi il
tasto Plot Attributes (in basso a sinistra). Nella finestra di dialogo "Define XY
Mappings" selezionare Symbols, selezionare il set di dati di interesse, quindi
Symbol show yes, e close.
Per uscire dal programma:
Quando si chiude il programma compare la richiesta: Save layout before exit?
Selezionare no